December 13th, 2010

Samba+LDAP но не PDC

Гугление наводит на грустные мысли о том, что если Samba с LDAP, то непременно DC.
У меня пользователи хранятся в LDAP. Для авторизации на рабочих станциях используется pGina с соответствующим плагином, замечательно цепляющаяся к LDAP.
Необходимо организовать файлпомойку на Samba + pam_mkhomedir, чтобы не создавать домашние каталоги юзверям на серваке.
Большинство программ вяжутся к LDAP по принципу userFilter-passwordFilter. Можно самбу настроить примерно таким же макаром?
stopstupid
  • dadv

[SOLVED] IPMI problem

Сервер SuperMicro SuperServer 5016T-MTFB на материнской плате X8STI-F имеет встроенную плату IPMI 2.0 (firmware 1.07, последняя) с выделенным ethernet-портом 100M. В BIOS выставлены IP-адреса, ipmitool их видит, на плате включена отправка Gratuitous ARP каждые 10 секунд, линк на порту поднялся. Но никаких пакетов с порта не поступает, ни Gratuitous ARP, ни ответов на ARP-запросы. Соответственно, зайти на IPMI нельзя.

Что я делаю не так?

ipmitool> lan print 1           
Set in Progress         : Set Complete 
Auth Type Support       : NONE MD2 MD5 OEM
Auth Type Enable        : Callback : NONE MD2 MD5 OEM
                        : User     : NONE MD2 MD5 OEM
                        : Operator : NONE MD2 MD5 OEM
                        : Admin    : NONE MD2 MD5 OEM
                        : OEM      :
IP Address Source       : Static Address
IP Address              : X.X.X.222     
Subnet Mask             : 255.255.255.252     
MAC Address             : 00:30:48:d0:d4:60     
SNMP Community String   : AMI     
IP Header               : TTL=0x00 Flags=0x00 Precedence=0x00 TOS=0x00
BMC ARP Control         : ARP Responses Enabled, Gratuitous ARP Enabled
Gratituous ARP Intrvl   : 10.0 seconds
Default Gateway IP      : X.X.X.221     
Default Gateway MAC     : 00:00:00:00:00:00     
Backup Gateway IP       : 0.0.0.0     
Backup Gateway MAC      : 00:00:00:00:00:00     
802.1q VLAN ID          : Disabled     
802.1q VLAN Priority    : 0     
RMCP+ Cipher Suites     : 1,2,3,6,7,8,11,12,0     
Cipher Suite Priv Max   : aaaaXXaaaXXaaXX     
                        :     X=Cipher Suite Unused
                        :     c=CALLBACK 
                        :     u=USER 
                        :     o=OPERATOR 
                        :     a=ADMIN 
                        :     O=OEM


Update: видимо, проблема была в том, что при вставлении кабеля питания в систему в выделенный ethernet-порт IPMI не был включен патч-корд до свича. Сделал наоборот - выдернул питание и подключил обратно при включенном патч-корде и всё заработало. Судя по http://www.supermicro.com/manuals/other/Embedded_BMC_IPMI.pdf, это документированное поведение и так и должно быть :-(