Category: история

Category was added automatically. Read all entries about "история".

APC SMT750I и его runtime

Есть APC SMT750I, ему пару лет. И он чего-то показывает ну очень маленький runtime в мониторинг. Ну и на самом деле ведёт себя так же, как и показывает. Отключаешь ему электричество, и он через 7-9 минут уже того, хотя на этой нагрузке должен хотя бы минут 30-40 жить. Батарейки есть родные с наклейкой CSB и датой 1801, есть и не родные, тоже CSB, с датой 1901. Всё свежее и как бы должно. Калибровку с морды запускал. Что вот можно с ним сделать? Ниже вывод apcaccess из apcupsd. apcupsd.conf по ссылке. Платформа — Debian Linux 9.


Collapse )
UPD: Проблема также оказалась в моей невнимательности к "STATUS   : COMMLOST". Осталось загадкой почему при COMMLOST apcupsd вообще показывало какие-то цифры типа "TIMELEFT : 9.0 Minutes". Цифры "9.0 Minutes" также были и на морде. Цифры чудным образом вылечились и стали адекватными "50.0 Minutes" после отключения-подключения батарей и запуска калибровки. Возможно я ошибся при наблюдении и принял жёсткое отключение питания за отключение по команде от ОС. Итог: установлены родные батареи с датой 1801, вместо кабеля COM использован кабель USB.
eyes

Dovecot2 — наведение порядка в папках

Приветствую, коллеги.

Дано: почтовый сервер на базе Postfix + Dovecot2. Всё работает, в принципе даже неплохо, но хочется сделать лучше.

Что не так?
Пользователи пользовались почтой. Годами. Разными клиентами. Поэтому у одного пользователя можно обнаружить одновременно папки .Spam, .Junk, .&BCEEHwQQBBw- и даже .&BB0ENQQ2BDUEOwQwBEIENQQ7BEwEPQQwBE8- &BD8EPgRHBEIEMA- (и это только касательно спама).

Collapse )

Что думаете, бояре?

upd: внимательно перечитал описание mailbox_alias и отбросил его за ненадобностью. Проверил, что происходит при автосоздании каталогов с автоподпиской и выяснил следующее:
- создаётся новый каталог (напрмер, "спам". Рядом со старым. Во всех клиентах)
- при этом проблема только с аутлуком. Он не понимает, что Junk это спам (в смысле — что в интерфейсе его неплохо бы по русски обозвать)
- если создать новый каталог и удалить старый, то из тандербёрда и раундкуба он удаляется, а вот из аутлука — нет. Мало того, аутлук повторно создаёт на сервере уже удалённый каталог.

В общем, со стороны сервера копать бесполезно, надо копать в сторону аутлука.
Тема временно похоронена.
  • dil

Странные грабельки в NATе

Ну и раз уж наступила пятница, ещё одна таинственная загадка - на сей раз про pfsense.

Итак, имеется локальная сетка с приватными адресами. Гейтом в интернеты работает pfsense в режиме NAT, у него на внешнем интерфейсе публичный IP.

Задача: подключить гостевой wifi, чтобы из него можно было ходить только наружу, а в локальную сетку низзя! Естественный способ - подключить wifiный рутер непосредственно к pfsense'у - не подходит, ибо wifi нужен в физически другом здании. Через VLAN тоже не получается, поскольку здания соединены не напрямую, а через интернет-провайдера, в свитчи которого доступа нету. Настроить файрвол на самом вайфайном AP не вышло, там эти настройки исключительно кривые (Asus, если чё). Что тут поделать.. подключить AP через отдельный файрвол. Для этого решили использовать уже готовый второй pfsense.

Казалось бы, задача элементарная, но, как всегда, есть нюансы:Collapse )
wut?
  • mit_yau

Джентльмены, имел кто-нибудь дело с 3proxy? [SOLVED]

Не могу добиться, чтоб работала цепочка по "parent".
[конфиг]

Конфиг:

#!/usr/local/bin/3proxy
#daemon
nserver 10.8.0.1
nscache 65536
monitor /usr/local/etc/3proxy/3proxy.cfg
timeouts 1 5 30 60 180 1800 15 60
log /var/log/3proxy/3proxy.log D
logformat "L%C:%c - %U [%d/%o/%Y:%H:%M:%S %z] ""%T"" %E %I %O %N:%p/%Q:%q - %R:%r"
archiver gz /bin/gzip %F
rotate 30
auth iponly
allow *
parent 1000 http 10.8.0.1 3128
external 10.8.0.6
internal 192.168.3.5
flush
auth none
dnspr
flush
auth none
allow *
proxy -n -a -p8080



Прокси на концах VPN-канала (openVPN), канал работает нормально, прокси на сервере (3proxy же с почти таким же конфигом, но без parent) работает нормально (на клиенте дополнительно поставлен для контроля polipо, который вполне нормально цепляется), браузер с клиента с прокси на сервере работает нормально.
В браузере через прокси клиента - ошибка 502. В логе строчки типа:

192.168.3.100:55030 - - [19/Jan/2015:16:18:15 +0300] "GET http://www.mozilla.org/ HTTP/1.1" 00013 0 0 PROXY:8080/63.245.215.20:80 - 63.245.215.20:80

Ошибка 13 согласно мануалу - "13 - сбой подключения connect() ". Какой именно сбой - непонятно, бо никакой дополнительной диагностики автором не предусмотрено.
На обоих концах Дебиан, если кому интересно.
Сталкивался ли кто-нибудь? И что я делаю не так?

UPD. Решено.
Конфиг должен выглядеть так:
[Spoiler (click to open)]

#!/usr/local/bin/3proxy
#daemon
nserver 10.8.0.1
nscache 65536
monitor /usr/local/etc/3proxy/3proxy.cfg
timeouts 1 5 30 60 180 1800 15 60
log /var/log/3proxy/3proxy.log D
logformat "L%C:%c - %U [%d/%o/%Y:%H:%M:%S %z] ""%T"" %E %I %O %N:%p/%Q:%q - %R:%r"
archiver gz /bin/gzip %F
rotate 30
external 10.8.0.6
internal 192.168.3.5
flush
auth none
dnspr
flush
auth iponly
allow *
parent 1000 http 10.8.0.1 3128
proxy -n -a -p8080

  • guest_o

OpenVPN и раздача IP-адресов

Что-то я не вкуриваю в этом OpenVPN. Прописано в конфиге сервера:

server 192.168.5.0 255.255.255.240

При подключении клиента на интерфейсе сервера tun0:

tun0: flags=8051<UP,POINTOPOINT,RUNNING,MULTICAST> metric 0 mtu 1500
options=80000<LINKSTATE>
inet 192.168.5.1 --> 192.168.5.2 netmask 0xffffffff
nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
Opened by PID 1738

Таблица маршрутизации на сервере:

Internet:
Destination Gateway Flags Refs Use Netif Expire
default 172.31.0.1 UGS 0 25329 xn0
127.0.0.1 link#1 UH 0 0 lo0
172.31.0.0/20 link#2 U 0 198 xn0
172.31.11.229 link#2 UHS 0 0 lo0
192.168.5.0/28 192.168.5.2 UGS 0 0 tun0
192.168.5.1 link#3 UHS 0 0 lo0
192.168.5.2 link#3 UH 0 10 tun0

Клиенту при этом выдаётся адрес 192.168.5.6. Который пингуется.
А вот адрес 192.168.5.2 нигде больше не фигурирует, не пингуется и это вообще что и откуда?!

Ну и ещё интересно, что непосредственно с клиента (это микротик) пингуется серверная сторона (192.168.5.1), а вот с компа за микротиком, для которого этот микротик является шлюзом по умолчанию, адрес 192.168.5.1 не пингуется, и даже до сервера не доходит, хотя сниффер пакетов на микротике показывает, что пинг от рабочей станции запихнут в OpenVPN-интерфейс микротика. Однако tcpdump -i tun0 на сервере никаких пакетов не видит. Вот как это может быть?
logo

Зависимость iops raid10 от кол-ва дисков

(Посчитаем что последняя неделя года одна такая большая пятница так что всем пива и свитеров)
Господа вопрос такой... вот есть у меня raid10 из 8 дисков на p410i контроллере и дает он грубо говоря мне 2500 IOPS
Так же есть у меня raid10 из 4х дисков на LSI MegaRAID который дает мне 1680 IOPS.
Вопрос: Какой шанс что если я докину еще 4 диска в LSI то я смогу догнать p410 по IOPS ?
linux

IE (7, 8, 9) зависает при открытии яндекса через squid

Вот такая необычная проблема.
Squid 2.7, версии IE разные, при открытии главной страницы яндекса браузер подвисает на некоторое время (от минуты и до пяти). В access.log при этом вот такая активность:

после этой строчки IE виснет - 192.168.1.20 TCP_MISS/200 26245 GET http://awaps.yandex.ru/0/216/0.? username DIRECT/77.88.21.131 application/x-shockwave-flash
эта строчка в логе появляется сразу за предыдущей, но через n минут - 192.168.1.20 TCP_MISS/504 1786 GET http://ipv6.yandex.ru/_e.gif? username DIRECT/ipv6.yandex.ru text/html

Когда отвиснет - всё отлично, быстро открывает страницы. FF не подвержен проблеме, IE без прокси - тоже. Замечено пока что только на yandex.ru, остальные страницы пока ок.
Погуглил, ничего не нашёл. К терапевту?
  • Current Music
    Tool - Triad (stealkill)

Настройка Alcatel 1660 sm

Добрый день!
Довольно срочно нужна консультация по пуско-наладке данного оборудования, может быть и сама пуско-наладка.
Все, конечно же, за деньги.
Предложения можно отправлять в личку.
Спасибо!